Mirus Closes Unexpectedly or Locks Up
8 Nov 2024
Problem:
Mirus closes unexpectedly or locks up intermittently
Cause(s):
- Windows is not being updated or has pending updates.
- The driver software connecting Mirus to CAN is improperly installed, needs to be updated, or is not running.
Solution:
- Install any pending Window updates by connecting the device to the internet, check for Windows updates, download and install updates, check for updates again and continue this process until all Windows updates are installed.
- Refer to steps outlined here.
Note: Regularly update your Windows operating system to keep Mirus and Windows functioning properly. Avoid disabling all Windows updates or scans.
If the problem persists, contact the HarvestMaster Field Service Engineers. For contact information, see Contact a HarvestMaster Field Service Engineer.
- Phone Number: 435-753-1881
- Email: hmtechsupport@junipersys.com
- Address: 1132 W 1700 N, Logan, UT 84321